You are not logged in.

/!\ We are moving to a new board. Come join us. This board will go into read-only mode on 20.06. /!\

1

Friday, May 11th 2018, 8:47pm

Lechif Lord quest glitched ?

Been trying for a few days now to do this quest "Lechif Lord"

I speak with Midonor to enter Dalinham Castle, where there is 3 NPC's "Jessie Mocliff" "Panilor" and "Yagean Kanches" all who i have tried to speak to, but the only option i have is "Leave Conversation". Run all over the castle multiple times to no reward, there is 2 portals, 1 i cant enter and the other leaves the castle.

Any help would be great.

Thanks

Fifio

Professional

Posts: 1,532

Location: Finland

  • Send private message

2

Friday, May 11th 2018, 9:25pm

With no maintenance for weeks most likely it is bugged as many other quests they get stuck if no maintenance.

I would try to contact support.

3

Friday, May 11th 2018, 9:36pm

He cant, support doesnt send email out to activate. Asked this zone to be restarted now over 5 days ago and still no progress. At least if they arent going to do maint, they should be restarting all zones frequently.

4

Friday, May 11th 2018, 10:17pm

tried to contact support, still waiting on an activation email for the support side, complete joke, considering this quest is linked to a huge quest chain :/

Fifio

Professional

Posts: 1,532

Location: Finland

  • Send private message

5

Friday, May 11th 2018, 10:51pm

Well hopefully maybe we get next week a maintenance ^_^ if no support

6

Sunday, May 13th 2018, 5:21pm

The zone where this quest is located has now been restarted.